A Microsoft Outlook email forum. Outlook Banter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » Outlook Banter forum » Microsoft Outlook Email Newsgroups » Outlook - General Queries
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

'Stop Processing More Rules' not working



 
 
Thread Tools Search this Thread Display Modes
  #1  
Old February 4th 08, 07:36 AM posted to microsoft.public.outlook
Amit
external usenet poster
 
Posts: 13
Default 'Stop Processing More Rules' not working

Hi,

I am having some problems using ‘Stop processing more rules’ directive in
outlook rules. Specifically the 'Stop Processing More Rules' directive seems
to apply to a message regardless of whether or not the message meets the
condition specified in the rule. The result is that only the first rule in my
rule list seems to work. To be noted that the conditions that I am using
cause the rules to be 'Client Only'.

Details:
I have rules like this


Apply the rule after message arrives
If (some conditions are satisfied)
(take some action)
Stop processing more rules

The conditions that I am using make the rule 'Client Only'.

I was expecting that ‘Stop processing more rules’ would kick in only if the
condition specified in the rule is satisfied. But what I am seeing is that
the ‘stop processing more rules’ kicks in regardless of whether or not the
message meets the criteria specified in the rule. The result is that none of
the following rules, which have criteria that would have been satisfied and
would have processed that message, get executed.

Can people please point to a solution? Much appreciate your help in this
matter.

Ads
  #2  
Old February 4th 08, 07:55 AM posted to microsoft.public.outlook
F.H. Muffman
external usenet poster
 
Posts: 536
Default 'Stop Processing More Rules' not working

Hi,

I am having some problems using 'Stop processing more rules' directive
in outlook rules. Specifically the 'Stop Processing More Rules'
directive seems to apply to a message regardless of whether or not the
message meets the condition specified in the rule. The result is that
only the first rule in my rule list seems to work. To be noted that
the conditions that I am using cause the rules to be 'Client Only'.

Details:
I have rules like this
"
Apply the rule after message arrives
If (some conditions are satisfied)
(take some action)
Stop processing more rules
"
The conditions that I am using make the rule 'Client Only'.
I was expecting that 'Stop processing more rules' would kick in only
if the condition specified in the rule is satisfied. But what I am
seeing is that the 'stop processing more rules' kicks in regardless of
whether or not the message meets the criteria specified in the rule.
The result is that none of the following rules, which have criteria
that would have been satisfied and would have processed that message,
get executed.



That action only happens if the rule fires upon the message, so if this is
the first rule, then it's firing against the message. Are the other actions
of the rule firing against the message? If it's not this rule, it's some
other rule that is firing against the message that is keeping other rules
from firing, or no other rules match the message.

--
-f.h.


  #3  
Old February 4th 08, 10:19 AM posted to microsoft.public.outlook
Amit
external usenet poster
 
Posts: 13
Default 'Stop Processing More Rules' not working

I was also expecting that the action would fire only on matching the rule
condition. But that is not the case. The 'Stop Processing More Rules' action
is firing regardless of whether or not the condition is met.

"F.H. Muffman" wrote:

Hi,

I am having some problems using 'Stop processing more rules' directive
in outlook rules. Specifically the 'Stop Processing More Rules'
directive seems to apply to a message regardless of whether or not the
message meets the condition specified in the rule. The result is that
only the first rule in my rule list seems to work. To be noted that
the conditions that I am using cause the rules to be 'Client Only'.

Details:
I have rules like this
"
Apply the rule after message arrives
If (some conditions are satisfied)
(take some action)
Stop processing more rules
"
The conditions that I am using make the rule 'Client Only'.
I was expecting that 'Stop processing more rules' would kick in only
if the condition specified in the rule is satisfied. But what I am
seeing is that the 'stop processing more rules' kicks in regardless of
whether or not the message meets the criteria specified in the rule.
The result is that none of the following rules, which have criteria
that would have been satisfied and would have processed that message,
get executed.



That action only happens if the rule fires upon the message, so if this is
the first rule, then it's firing against the message. Are the other actions
of the rule firing against the message? If it's not this rule, it's some
other rule that is firing against the message that is keeping other rules
from firing, or no other rules match the message.

--
-f.h.



  #4  
Old February 4th 08, 02:07 PM posted to microsoft.public.outlook
Brian Tillman
external usenet poster
 
Posts: 17,452
Default 'Stop Processing More Rules' not working

Amit wrote:

I was also expecting that the action would fire only on matching the
rule condition. But that is not the case. The 'Stop Processing More
Rules' action is firing regardless of whether or not the condition is
met.


You'd have to prove that. State the exact rule and an example of a message
you think shouldn't match the rule but appears to do so.
--
Brian Tillman [MVP-Outlook]

  #5  
Old February 5th 08, 04:44 AM posted to microsoft.public.outlook
F.H. Muffman
external usenet poster
 
Posts: 536
Default 'Stop Processing More Rules' not working

I am having some problems using 'Stop processing more rules'
directive in outlook rules. Specifically the 'Stop Processing More
Rules' directive seems to apply to a message regardless of whether
or not the message meets the condition specified in the rule. The
result is that only the first rule in my rule list seems to work. To
be noted that the conditions that I am using cause the rules to be
'Client Only'.

Details:
I have rules like this
"
Apply the rule after message arrives
If (some conditions are satisfied)
(take some action)
Stop processing more rules
"
The conditions that I am using make the rule 'Client Only'.
I was expecting that 'Stop processing more rules' would kick in only
if the condition specified in the rule is satisfied. But what I am
seeing is that the 'stop processing more rules' kicks in regardless of
whether or not the message meets the criteria specified in the rule.
The result is that none of the following rules, which have criteria
that would have been satisfied and would have processed that
message, get executed.


That action only happens if the rule fires upon the message, so if
this is the first rule, then it's firing against the message. Are
the other actions of the rule firing against the message? If it's
not this rule, it's some other rule that is firing against the
message that is keeping other rules from firing, or no other rules
match the message.


I was also expecting that the action would fire only on matching the
rule condition. But that is not the case. The 'Stop Processing More
Rules' action is firing regardless of whether or not the condition is
met.


It isn't that I don't believe you, I believe you're seeing what you're seeing.
What I don't believe is that Outlook isn't behaving properly. It simply
isn't behaving the way you think it should. Believe me, of all the parts
of Outlook that tend to go wrong, Rules is about 99.999% solid, especially
when it comes to basic processing of rules.

This first rule, what is the action it is doing?

Here's what I would do. Export all rules. Delete all rules but this one.
Add an action that you'll notice, like the Display ____ in a New Item Window
action. Send a message that you think should be caught by the rule that
isn't firing. If you don't get the New Item Window, import the rules and
then delete all but the first and second rule. Lather, Rinse, Repeat.

I will guarantee you that you have a rule *before* the rule you think should
be catching this message that is catching the message.

Either that, or the rule you *think* should be catching the message isn't
because of something misconfigured in that rule.
--
-f.h.


  #6  
Old January 22nd 14, 04:57 PM
Ashok Bisht Ashok Bisht is offline
Junior Member
 
First recorded activity at Outlookbanter: Jan 2014
Posts: 1
Cool

Outlook has a bug and unfortunately till 2010. I am experiencing the exact same problem in outlook 2010. The work around is as below.

1. Move all client only rules at the bottom.
2. remove the stop processing from all the client only rules like moving to PST etc.. (I am mainly using moving to PST).
3. To avoid the problem of duplicate message which will come immediately after 2 is you need to put except condition which might be qualified in earlier rules. Some time this is impossible to write the exact except conditions then for the same purpose you might need to write the multiple rules. the limitation in the rules are you can have only AND conditions for qualifying and ONLY OR conditions on the except conditions.
 




Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rules Seem to Stop Working pestocat Outlook - General Queries 5 January 22nd 08 03:50 AM
stop processing rules [email protected] Outlook - General Queries 2 June 21st 07 11:39 AM
"stop processing more rules" why? Rob Outlook - General Queries 4 March 5th 07 06:21 PM
Help with Processing Rules Dan and Anna Outlook - General Queries 2 January 7th 07 10:11 PM
Failure of Rules Processing -- 2 Norman Litell Outlook Express 15 August 13th 06 06:41 AM


All times are GMT +1. The time now is 09:23 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.Search Engine Friendly URLs by vBSEO 2.4.0
Copyright 2004-2017 Outlook Banter.
The comments are property of their posters.