View Single Post
  #2  
Old February 4th 08, 07:55 AM posted to microsoft.public.outlook
F.H. Muffman
external usenet poster
 
Posts: 536
Default 'Stop Processing More Rules' not working

Hi,

I am having some problems using 'Stop processing more rules' directive
in outlook rules. Specifically the 'Stop Processing More Rules'
directive seems to apply to a message regardless of whether or not the
message meets the condition specified in the rule. The result is that
only the first rule in my rule list seems to work. To be noted that
the conditions that I am using cause the rules to be 'Client Only'.

Details:
I have rules like this
"
Apply the rule after message arrives
If (some conditions are satisfied)
(take some action)
Stop processing more rules
"
The conditions that I am using make the rule 'Client Only'.
I was expecting that 'Stop processing more rules' would kick in only
if the condition specified in the rule is satisfied. But what I am
seeing is that the 'stop processing more rules' kicks in regardless of
whether or not the message meets the criteria specified in the rule.
The result is that none of the following rules, which have criteria
that would have been satisfied and would have processed that message,
get executed.



That action only happens if the rule fires upon the message, so if this is
the first rule, then it's firing against the message. Are the other actions
of the rule firing against the message? If it's not this rule, it's some
other rule that is firing against the message that is keeping other rules
from firing, or no other rules match the message.

--
-f.h.


Ads